Kako uraditi downgrade Jave na 1.4.1 na Snow Leopa
Posted: 16 June 2010 11:27 AM
Member
RankRankRank
Total Posts:  96
Joined  2010-03-31

Imam dosta kompleksu aplikaciju za knjigovodstvene usluge koja je multiplatformska i koja zbog odredjenijh stvari zahteva rad sa Javaom verzije 1.4.1. Pa me interesuje da li je neko mozda imao iskustva i kako uraditi downgrade Jave na Snow Leopard-u.

Koga interesuje moze pogledati na http://www.micro.co.rs o kakvoj se aplikaciji radi, odnosno pre se moze nazvati poslovnim resenjem.

Hvala.

Profile
 
Posted: 16 June 2010 12:57 PM   [ # 1 ]
Sr. Member
Avatar
RankRankRankRank
Total Posts:  260
Joined  2007-09-07

Nažalost nikako.

 Signature 

iMac 27-inch

Profile
 
Posted: 16 June 2010 01:40 PM   [ # 2 ]
Sr. Member
Avatar
RankRankRankRank
Total Posts:  7538
Joined  2005-04-28

ttanaskovic wrote:

Nažalost nikako.

Da, za Java 1.4.1 izgleda nikako, međutim ovo sam iskopao za 1.5:

http://www.scribd.com/doc/22853741/Installing-Java-5-Back-on-Snow-Leopard

 Signature 

ACSP 10.10 - ACSP 10.9 - ACA 10.8 Mac Management - ACSP 10.8 -  ACSP 10.7 - ACSA 10.6

Profile
 
Posted: 16 June 2010 01:43 PM   [ # 3 ]
Sr. Member
Avatar
RankRankRankRank
Total Posts:  7538
Joined  2005-04-28

Možda ima nade:

http://tedwise.com/2009/09/25/using-java-1-5-and-java-1-4-on-snow-leopard/

 Signature 

ACSP 10.10 - ACSP 10.9 - ACA 10.8 Mac Management - ACSP 10.8 -  ACSP 10.7 - ACSA 10.6

Profile
 
Posted: 16 June 2010 01:45 PM   [ # 4 ]
Sr. Member
Avatar
RankRankRankRank
Total Posts:  1211
Joined  2008-11-18

izgleda da moze, a? Ili gresim?


Installing Java 1.4.2 and/or Java 1.5 on snow Leopard:

The following is based on two blog posts: Using Java 1.5 and Java 1.4 on Snow Leopard and Installing Java 1.5 on Snow Leopard:
Download the official Java package from Apple: Java for Mac OS X 10.5 Update 4, dated June 15, 2009.
Use the excellent shareware utility Pacifist to open the downloaded JavaForMacOSX10.5Update4.pkg file.
First use Finder to go to System » Library » Frameworks » JavaVM.framework » Versions and delete the two aliases (symlinks) 1.5 and 1.5.0. Don’t skip this step, because otherwise the extraction will follow the symlinks and overwrite the contents of the 1.6.0 folder, oops!
In Pacifist, drill down into Contents » System » Library » Frameworks » JavaVM.framework » Versions.
In Pacifist, select 1.5 and 1.5.0, Control-click on the selection, and chose Install to Default Location from the pop-up menu.
In the instructions above, the same applies for version 1.4.2.

 

Installing the Cocoa-Java Bridge:

This is based on Getting back the Cocoa-Java bridge in Snow Leopard:

Copy from a working Leopard (10.5) installation the following folders:
the com directory in /System/Library/Java
the eight files ending with .dylib in /usr/lib/java (four of these are regular files, the other four are symlinks; if you prefer, you can copy just the files and recreate the symlinks by hand).

 Signature 

.(JavaScript must be enabled to view this email address)

Profile
 
Posted: 16 June 2010 01:45 PM   [ # 5 ]
Sr. Member
Avatar
RankRankRankRank
Total Posts:  7538
Joined  2005-04-28

A i macosxhints.com ima nešto d akaže:

http://www.macosxhints.com/article.php?story=20100123192950640

 Signature 

ACSP 10.10 - ACSP 10.9 - ACA 10.8 Mac Management - ACSP 10.8 -  ACSP 10.7 - ACSA 10.6

Profile
 
Posted: 17 June 2010 08:49 AM   [ # 6 ]
Member
RankRankRank
Total Posts:  96
Joined  2010-03-31

Hvala na vremenu, probacu veceras da uradim downgrade. Mada sam ja nesto slicno radio na hackintosu dok jos nisam imao mac. Problem je bio sledeci on lepo prijavi da je java 1.4.1 instalirana ali kad pozovem iz terminala Java -version on idalje prijavljuje da je najsvezija verzija jave aktivna i aplikaciju mi pokrece u toj verziji sto meni nikako ne odgovara, ali mozda je to slucaj sa Hakintosom ja sam jos uvek zelen u mac svetu kupio sam mac pre neki dan.

Profile
 
Posted: 17 June 2010 12:17 PM   [ # 7 ]
Sr. Member
Avatar
RankRankRankRank
Total Posts:  7538
Joined  2005-04-28

Pročtaj dobro uputstva, ti u stvari nećeš raditi downgrade, već ćeš dodati 1.4.2 pored postojeće 1.6. Javlja ti da imaš već 1.4.2, a putanja ka njoj je u stvari simbolički UNIX link ka verziji 1.6. U uputsvima ćeš videti da taj link moraš da prekineš kada ubacuješ staru verziju. Kasnije sa aplikacijom ‘Java Preferences’ koja je u /Applications/Utilities/ određuješ prioritet verzija.

Nego, kao programera, doduše iz potpuno druge priče, me interesuje malo detaljnije i preciznije zašto tvoja aplikacija zahteva stariju verziju? naravno, ako nije neka poslovna tajna.

 Signature 

ACSP 10.10 - ACSP 10.9 - ACA 10.8 Mac Management - ACSP 10.8 -  ACSP 10.7 - ACSA 10.6

Profile
 
Posted: 17 June 2010 12:55 PM   [ # 8 ]
Sr. Member
Avatar
RankRankRankRank
Total Posts:  260
Joined  2007-09-07

Ja sam, kao java programer, često naletao na nepismene aplikacije, koje recimo ako se pokreću preko java web starta imaju zakucanu verziju jave na recimo 1.4 umesto 1.4+ ili jednostavno po startu provere koja je java pa ako nije to što smatra da treba da bude onda odbija da nastavi sa radom. Ovakve stvari je relativno lako rešiti.

Na žalost postoji i mnogo gori scenario, a to je da su korišćene deprecated metode/klase koje su u novijim verzijama jvm-a izbačene, a firma koja ima takav proizvod jednostavno neće ili nema resursa da ‘modernizuje’ kod.

 Signature 

iMac 27-inch

Profile
 
Posted: 17 June 2010 01:20 PM   [ # 9 ]
Sr. Member
Avatar
RankRankRankRank
Total Posts:  7538
Joined  2005-04-28

ttanaskovic wrote:

Na žalost postoji i mnogo gori scenario, a to je da su korišćene deprecated metode/klase koje su u novijim verzijama jvm-a izbačene, a firma koja ima takav proizvod jednostavno neće ili nema resursa da ‘modernizuje’ kod.

I ja bih, kao laik za Javu, ipak tipovao na ovo drugo.

E sad, u mom malom 4D svetu nam uredno par verzija unapred najave ‘ne koristite ovo, to ćemo da izbacimo’, tipičan primer je recimo tip polja ‘Subtable’ (BTW, s tim se sada bakćem, konvertujem jednu staru aplikaciju gde je čovek masovno koristio subtables); za koji su nam još pre više od 10 godina rekli: ‘ovo ćemo jednog dana izbaciti, nemojte više koristiti’. I izbacili su, u stvari i nisu, već su napravili neki compability layer gde su te subtabele automatski konvertovane u obične ‘many’ tabele sa vezama ka ‘one’ tabeli, ali se kod ne menja i sve radi.

Raširih priču, zar ne postoji nešto tako i kod vas?

 Signature 

ACSP 10.10 - ACSP 10.9 - ACA 10.8 Mac Management - ACSP 10.8 -  ACSP 10.7 - ACSA 10.6

Profile
 
Posted: 17 June 2010 01:23 PM   [ # 10 ]
Sr. Member
Avatar
RankRankRankRank
Total Posts:  7538
Joined  2005-04-28

Izvinite što mešam ovo u temu, Toplice molim te proveri PM.

 Signature 

ACSP 10.10 - ACSP 10.9 - ACA 10.8 Mac Management - ACSP 10.8 -  ACSP 10.7 - ACSA 10.6

Profile
 
Posted: 17 June 2010 02:27 PM   [ # 11 ]
Sr. Member
Avatar
RankRankRankRank
Total Posts:  260
Joined  2007-09-07

madamov wrote:

Raširih priču, zar ne postoji nešto tako i kod vas?

Pa postoji, ali ljudi vole da isključe deprecation warning kod kompajliranja, pa to ti je.

Inače, mislim da je po markiranju nečega u javi potrebno da prođu tri verzije pre nego što se to zaista i ukine.

No, baš kao što si rekao da ne širimo priču više.

@Karamunjos: Obavezno javi kako je prošlo.

 Signature 

iMac 27-inch

Profile